今天测试ASP.NET Padding Oracle漏洞,使用padBuster.pl的时候报如下错误:Can't locate Crypt/SSLeay.pm in @INC (@INC contains: D:/Perl64/site/lib D:/Perl64/lib .) at C:\padBuster.pl line 22.

BEGIN failed--compilation aborted at C:\padBuster.pl line 22.

网上搜索了一下,说是需要使用cpan安装缺失的pm包即可,测试了4次,每次以失败告终,版本测试过5.14及5.16版本都不行,报如下错误:

D:\Perl64\site\bin\dmake.exe -- NOT OK

无奈,到perl官方网站上面搜索,使用如下方法搞定: ppm install Crypt-SSLeay

成功运行padBuster.pl